ReddingITPro

Technical Blog of Jason Olson

I encountered a problem this week when using a newer version of Acronis (9.7) to create an image, and then using an older release (9.5) to restore it. Acronis does not detect that there is a version mismatch between the image and the restore software. However, in my case, it caused a BSOD pointing towards a driver problem. Using the correct version to backup and restore resolved the problem. Infact, I tested both 9.5 and 9.7 on this system, and as long as you used the same version for backup and restore it will work fine. It just doesn’t handle cross version very well.

Please follow and like us:

Leave a Reply